Skip to content
This repository has been archived by the owner on May 11, 2024. It is now read-only.

Latest commit

 

History

History

how-to-disable-cups-printer-job-history-on-macos

Folders and files

NameName
Last commit message
Last commit date

parent directory

..
 
 
 
 

How to disable CUPS printer job history on macOS

macOS stores a copy of everything one prints forever

Requirements

  • Computer running macOS Monterey or Ventura

Setup guide

Step 1: clear job history

Heads-up: purges /var/spool/cups.

$ cancel -a -x

Step 2: create /usr/local/sbin directory

sudo mkdir -p /usr/local/sbin
sudo chown ${USER}:admin /usr/local/sbin

Step 3: create cups.sh script

cat << "EOF" > /usr/local/sbin/cups.sh
#! /bin/sh

set -e

if grep -qe '^PreserveJobHistory Off$' /etc/cups/cupsd.conf; then
  exit 0
fi

echo "PreserveJobHistory Off" | sudo tee -a /etc/cups/cupsd.conf

sudo launchctl unload /System/Library/LaunchDaemons/org.cups.cupsd.plist

sudo launchctl load /System/Library/LaunchDaemons/org.cups.cupsd.plist
EOF

Step 4: make cups.sh executable

chmod +x /usr/local/sbin/cups.sh

Step 5: create local.cups.plist launch daemon

cat << "EOF" | sudo tee /Library/LaunchDaemons/local.cups.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  <dict>
    <key>Label</key>
    <string>local.cups</string>

    <key>ProgramArguments</key>
    <array>
        <string>/usr/local/sbin/cups.sh</string>
    </array>

    <key>RunAtLoad</key>
    <true/>
  </dict>
</plist>
EOF

Step 6: reboot

👍


Want things back the way they were before following this guide? No problem!

Step 1: delete PreserveJobHistory Off line from cupsd.conf

sudo sed -i "" "/PreserveJobHistory Off/d" /etc/cups/cupsd.conf

Step 2: delete cups.sh script

sudo rm /usr/local/sbin/cups.sh

Step 3: delete local.cups.plist launch daemon

sudo rm /Library/LaunchDaemons/local.cups.plist

Step 4: reload CUPS

sudo launchctl unload /System/Library/LaunchDaemons/org.cups.cupsd.plist

sudo launchctl load /System/Library/LaunchDaemons/org.cups.cupsd.plist

Step 5: reboot

👍